GET /api/v1/results/2818
HTTP 200 OK
Allow: GET, PUT, PATCH, DELETE, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept

{
    "id": 2818,
    "status": "ok",
    "playbook": {
        "id": 12,
        "items": {
            "plays": 13,
            "tasks": 206,
            "results": 150,
            "hosts": 1,
            "files": 104,
            "records": 0
        },
        "labels": [],
        "started": "2020-01-31T15:49:11.871862Z",
        "ended": "2020-01-31T15:53:58.165245Z",
        "duration": "00:04:46.293383",
        "name": null,
        "ansible_version": "2.8.8",
        "status": "completed",
        "path": "/home/zuul/src/opendev.org/openstack/openstack-ansible/playbooks/setup-hosts.yml"
    },
    "play": {
        "id": 42,
        "items": {
            "tasks": 155,
            "results": 113
        },
        "started": "2020-01-31T15:50:56.895994Z",
        "ended": "2020-01-31T15:53:56.741875Z",
        "duration": "00:02:59.845881",
        "name": "Apply security hardening configurations",
        "status": "completed",
        "playbook": 12
    },
    "task": {
        "id": 3626,
        "items": {
            "results": 1
        },
        "path": "/home/zuul/src/opendev.org/openstack/ansible-hardening/tasks/rhel7stig/auth.yml",
        "started": "2020-01-31T15:52:54.236005Z",
        "ended": "2020-01-31T15:52:54.714407Z",
        "duration": "00:00:00.478402",
        "name": "ansible-hardening : V-71947 - Users must provide a password for privilege escalation.",
        "action": "debug",
        "lineno": 121,
        "handler": false,
        "status": "completed",
        "play": 42,
        "file": 646,
        "playbook": 12
    },
    "host": {
        "id": 14,
        "name": "aio1",
        "changed": 43,
        "failed": 0,
        "ok": 123,
        "skipped": 27,
        "unreachable": 0,
        "playbook": 12
    },
    "content": {
        "changed": false,
        "msg": "The 'NOPASSWD' directive was found in the sudoers configuration files. Remove the directive to ensure that all users must provide a password to run commands as the root user.\n"
    },
    "created": "2020-01-31T15:52:54.894426Z",
    "updated": "2020-01-31T15:52:54.894470Z",
    "started": "2020-01-31T15:52:54.236005Z",
    "ended": "2020-01-31T15:52:54.498833Z",
    "duration": "00:00:00.262828",
    "changed": false,
    "ignore_errors": false
}