GET /api/v1/results/3757
HTTP 200 OK
Allow: GET, PUT, PATCH, DELETE, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept

{
    "id": 3757,
    "status": "changed",
    "playbook": {
        "id": 21,
        "items": {
            "plays": 20,
            "tasks": 208,
            "results": 168,
            "hosts": 1,
            "files": 189,
            "records": 0
        },
        "labels": [],
        "started": "2020-01-31T15:53:31.538179Z",
        "ended": "2020-01-31T15:59:11.725650Z",
        "duration": "00:05:40.187471",
        "name": null,
        "ansible_version": "2.8.8",
        "status": "completed",
        "path": "/home/zuul/src/opendev.org/openstack/openstack-ansible/playbooks/setup-infrastructure.yml"
    },
    "play": {
        "id": 111,
        "items": {
            "tasks": 13,
            "results": 11
        },
        "started": "2020-01-31T15:55:28.873656Z",
        "ended": "2020-01-31T15:55:43.654898Z",
        "duration": "00:00:14.781242",
        "name": "Install memcached",
        "status": "completed",
        "playbook": 21
    },
    "task": {
        "id": 4573,
        "items": {
            "results": 1
        },
        "path": "/home/zuul/src/opendev.org/openstack/openstack-ansible-memcached_server/tasks/memcached_install.yml",
        "started": "2020-01-31T15:55:30.834518Z",
        "ended": "2020-01-31T15:55:34.484639Z",
        "duration": "00:00:03.650121",
        "name": "memcached_server : Install distro packages",
        "action": "package",
        "lineno": 16,
        "handler": false,
        "status": "completed",
        "play": 111,
        "file": 1827,
        "playbook": 21
    },
    "host": {
        "id": 22,
        "name": "aio1",
        "changed": 67,
        "failed": 0,
        "ok": 142,
        "skipped": 25,
        "unreachable": 0,
        "playbook": 21
    },
    "content": {
        "attempts": 1,
        "cache_update_time": 1580486075,
        "cache_updated": false,
        "changed": true,
        "stderr": "",
        "stderr_lines": [],
        "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\nThe following package was automatically installed and is no longer required:\n  libopts25\nUse 'apt autoremove' to remove it.\nSuggested packages:\n  libcache-memcached-perl libmemcached libanyevent-perl libyaml-perl\n  libterm-readkey-perl\nThe following NEW packages will be installed:\n  memcached\n0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.\nNeed to get 109 kB of archives.\nAfter this operation, 293 kB of additional disk space will be used.\nGet:1 http://mirror.iad.rax.openstack.org/ubuntu bionic-updates/main amd64 memcached amd64 1.5.6-0ubuntu1.2 [109 kB]\nFetched 109 kB in 0s (0 B/s)\nSelecting previously unselected package memcached.\r\n(Reading database ... \r(Reading database ... 5%\r(Reading database ... 10%\r(Reading database ... 15%\r(Reading database ... 20%\r(Reading database ... 25%\r(Reading database ... 30%\r(Reading database ... 35%\r(Reading database ... 40%\r(Reading database ... 45%\r(Reading database ... 50%\r(Reading database ... 55%\r(Reading database ... 60%\r(Reading database ... 65%\r(Reading database ... 70%\r(Reading database ... 75%\r(Reading database ... 80%\r(Reading database ... 85%\r(Reading database ... 90%\r(Reading database ... 95%\r(Reading database ... 100%\r(Reading database ... 41530 files and directories currently installed.)\r\nPreparing to unpack .../memcached_1.5.6-0ubuntu1.2_amd64.deb ...\r\nUnpacking memcached (1.5.6-0ubuntu1.2) ...\r\nSetting up memcached (1.5.6-0ubuntu1.2) ...\r\nCreated symlink /etc/systemd/system/multi-user.target.wants/memcached.service -> /lib/systemd/system/memcached.service.\r\nProcessing triggers for systemd (237-3ubuntu10.33) ...\r\n",
        "stdout_lines": [
            "Reading package lists...",
            "Building dependency tree...",
            "Reading state information...",
            "The following package was automatically installed and is no longer required:",
            "  libopts25",
            "Use 'apt autoremove' to remove it.",
            "Suggested packages:",
            "  libcache-memcached-perl libmemcached libanyevent-perl libyaml-perl",
            "  libterm-readkey-perl",
            "The following NEW packages will be installed:",
            "  memcached",
            "0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.",
            "Need to get 109 kB of archives.",
            "After this operation, 293 kB of additional disk space will be used.",
            "Get:1 http://mirror.iad.rax.openstack.org/ubuntu bionic-updates/main amd64 memcached amd64 1.5.6-0ubuntu1.2 [109 kB]",
            "Fetched 109 kB in 0s (0 B/s)",
            "Selecting previously unselected package memcached.",
            "(Reading database ... ",
            "(Reading database ... 5%",
            "(Reading database ... 10%",
            "(Reading database ... 15%",
            "(Reading database ... 20%",
            "(Reading database ... 25%",
            "(Reading database ... 30%",
            "(Reading database ... 35%",
            "(Reading database ... 40%",
            "(Reading database ... 45%",
            "(Reading database ... 50%",
            "(Reading database ... 55%",
            "(Reading database ... 60%",
            "(Reading database ... 65%",
            "(Reading database ... 70%",
            "(Reading database ... 75%",
            "(Reading database ... 80%",
            "(Reading database ... 85%",
            "(Reading database ... 90%",
            "(Reading database ... 95%",
            "(Reading database ... 100%",
            "(Reading database ... 41530 files and directories currently installed.)",
            "Preparing to unpack .../memcached_1.5.6-0ubuntu1.2_amd64.deb ...",
            "Unpacking memcached (1.5.6-0ubuntu1.2) ...",
            "Setting up memcached (1.5.6-0ubuntu1.2) ...",
            "Created symlink /etc/systemd/system/multi-user.target.wants/memcached.service -> /lib/systemd/system/memcached.service.",
            "Processing triggers for systemd (237-3ubuntu10.33) ..."
        ]
    },
    "created": "2020-01-31T15:55:34.351481Z",
    "updated": "2020-01-31T15:55:34.351521Z",
    "started": "2020-01-31T15:55:30.834518Z",
    "ended": "2020-01-31T15:55:34.073839Z",
    "duration": "00:00:03.239321",
    "changed": true,
    "ignore_errors": false
}