/home/zuul/src/opendev.org/openstack/openstack-ansible/playbooks/openstack-hosts-setup.yml
---
# Copyright 2014, Rackspace US, Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
#     http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
# See the License for the specific language governing permissions and
# limitations under the License.

# NOTE(mhayden): CentOS always has python (because of yum), but it's possible
# that Ubuntu nodes may not have python by default. Ansible doesn't work very
# well if Python isn't installed.
#
# Also, we can't use a 'when' to check for the ansible_pkg_mgr here because
# we haven't gathered facts yet.
- name: Install Ansible prerequisites
  hosts: "{{ openstack_host_group|default('hosts') }}"
  gather_facts: false
  user: root
  pre_tasks:
    - name: Ensure python is installed
      register: result
      raw: |
        if which apt-get >/dev/null && ! which python >/dev/null ; then
          if ! which python3 >/dev/null ; then
            apt-get -y install python3
          fi
          update-alternatives --install /usr/bin/python python /usr/bin/python3 10
          exit 2
        else
          exit 0
        fi
      changed_when: "result.rc == 2"
      failed_when: "result.rc not in [0, 2]"

- name: Basic host setup
  hosts: "{{ openstack_host_group|default('hosts') }}"
  gather_facts: "{{ osa_gather_facts | default(True) }}"
  user: root
  pre_tasks:
    - name: Check for a supported Operating System
      assert:
        that:
          - (ansible_distribution == 'Debian' and ansible_distribution_release == 'stretch') or
            (ansible_distribution == 'Debian' and ansible_distribution_release == 'buster') or
            (ansible_distribution == 'Ubuntu' and ansible_distribution_release == 'bionic') or
            (ansible_os_family == 'RedHat' and ansible_distribution_major_version == '7') or
            (ansible_os_family == 'Suse' and ansible_distribution_major_version in ['15', '42'])
        msg: "The only supported platforms for this release are Debian Stretch or Buster, Ubuntu 18.04 LTS (Bionic),  CentOS 7 (WIP) and openSUSE Leap 42.X and openSUSE Leap 15.X"

    - include_tasks: common-tasks/package-cache-proxy.yml
      when: install_method == "source"
  roles:
    - role: "openstack_hosts"
  vars_files:
    - defaults/repo_packages/openstack_services.yml
    - "defaults/{{ install_method }}_install.yml"
  environment: "{{ deployment_environment_variables | default({}) }}"
  tags:
    - openstack-hosts