Details

Result

Field Value
attempts
1
changed
True
cmd
[
    "/openstack/venvs/utility-20.1.0.dev115/bin/pip",
    "install",
    "-U",
    "--constraint",
    "/openstack/venvs/utility-20.1.0.dev115/global-constraints.txt",
    "--constraint",
    "/openstack/venvs/utility-20.1.0.dev115/constraints.txt",
    "--log",
    "/var/log/python_venv_build.log",
    "--find-links",
    "http://172.29.236.100:8181/os-releases/20.1.0.dev115/debian-10-x86_64",
    "--trusted-host",
    "172.29.236.100",
    "pip",
    "setuptools",
    "wheel"
]
name
[
    "pip",
    "setuptools",
    "wheel"
]
requirements None
state
latest
stderr

stderr_lines
[]
stdout
Ignoring argparse: markers 'python_version == "2.7"' don't match your environment
Looking in links: http://172.29.236.100:8181/os-releases/20.1.0.dev115/debian-10-x86_64
Collecting pip==19.3 (from -c /openstack/venvs/utility-20.1.0.dev115/global-constraints.txt (line 2))
  Downloading https://files.pythonhosted.org/packages/4a/08/6ca123073af4ebc4c5488a5bc8a010ac57aa39ce4d3c8a931ad504de4185/pip-19.3-py2.py3-none-any.whl (1.4MB)
Collecting setuptools==41.4.0 (from -c /openstack/venvs/utility-20.1.0.dev115/global-constraints.txt (line 3))
  Downloading https://files.pythonhosted.org/packages/6a/9a/50fadfd53ec909e4399b67c74cc7f4e883488035cfcdb90b685758fa8b34/setuptools-41.4.0-py2.py3-none-any.whl (580kB)
Collecting wheel==0.33.6 (from -c /openstack/venvs/utility-20.1.0.dev115/global-constraints.txt (line 4))
  Downloading https://files.pythonhosted.org/packages/00/83/b4a77d044e78ad1a45610eb88f745be2fd2c6d658f9798a15e384b7d57c9/wheel-0.33.6-py2.py3-none-any.whl
Installing collected packages: pip, setuptools, wheel
  Found existing installation: pip 18.1
    Uninstalling pip-18.1:
      Successfully uninstalled pip-18.1
  Found existing installation: setuptools 40.8.0
    Uninstalling setuptools-40.8.0:
      Successfully uninstalled setuptools-40.8.0
  Found existing installation: wheel 0.32.3
    Uninstalling wheel-0.32.3:
      Successfully uninstalled wheel-0.32.3
Successfully installed pip-19.3 setuptools-41.4.0 wheel-0.33.6
stdout_lines
[
    "Ignoring argparse: markers 'python_version == \"2.7\"' don't match your environment",
    "Looking in links: http://172.29.236.100:8181/os-releases/20.1.0.dev115/debian-10-x86_64",
    "Collecting pip==19.3 (from -c /openstack/venvs/utility-20.1.0.dev115/global-constraints.txt (line 2))",
    "  Downloading https://files.pythonhosted.org/packages/4a/08/6ca123073af4ebc4c5488a5bc8a010ac57aa39ce4d3c8a931ad504de4185/pip-19.3-py2.py3-none-any.whl (1.4MB)",
    "Collecting setuptools==41.4.0 (from -c /openstack/venvs/utility-20.1.0.dev115/global-constraints.txt (line 3))",
    "  Downloading https://files.pythonhosted.org/packages/6a/9a/50fadfd53ec909e4399b67c74cc7f4e883488035cfcdb90b685758fa8b34/setuptools-41.4.0-py2.py3-none-any.whl (580kB)",
    "Collecting wheel==0.33.6 (from -c /openstack/venvs/utility-20.1.0.dev115/global-constraints.txt (line 4))",
    "  Downloading https://files.pythonhosted.org/packages/00/83/b4a77d044e78ad1a45610eb88f745be2fd2c6d658f9798a15e384b7d57c9/wheel-0.33.6-py2.py3-none-any.whl",
    "Installing collected packages: pip, setuptools, wheel",
    "  Found existing installation: pip 18.1",
    "    Uninstalling pip-18.1:",
    "      Successfully uninstalled pip-18.1",
    "  Found existing installation: setuptools 40.8.0",
    "    Uninstalling setuptools-40.8.0:",
    "      Successfully uninstalled setuptools-40.8.0",
    "  Found existing installation: wheel 0.32.3",
    "    Uninstalling wheel-0.32.3:",
    "      Successfully uninstalled wheel-0.32.3",
    "Successfully installed pip-19.3 setuptools-41.4.0 wheel-0.33.6"
]
version None
virtualenv
/openstack/venvs/utility-20.1.0.dev115