Details

Result

Field Value
attempts
1
changed
True
cmd
[
    "/openstack/venvs/utility-20.1.0.dev115/bin/pip",
    "install",
    "-U",
    "--constraint",
    "/openstack/venvs/utility-20.1.0.dev115/global-constraints.txt",
    "--constraint",
    "/openstack/venvs/utility-20.1.0.dev115/constraints.txt",
    "--log",
    "/var/log/python_venv_build.log",
    "pip",
    "setuptools",
    "wheel"
]
name
[
    "pip",
    "setuptools",
    "wheel"
]
requirements None
state
latest
stderr

stderr_lines
[]
stdout
Ignoring argparse: markers 'python_version == "2.7"' don't match your environment
Ignoring enum-compat: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-actdiag: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-actdiag: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-actdiag: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-actdiag: markers 'python_version == "3.6"' don't match your environment
Ignoring pytest: markers 'python_version == "2.7"' don't match your environment
Ignoring pytest: markers 'python_version == "3.4"' don't match your environment
Ignoring pytest: markers 'python_version == "3.5"' don't match your environment
Ignoring pytest: markers 'python_version == "3.6"' don't match your environment
Ignoring sphinxcontrib-nwdiag: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-nwdiag: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-nwdiag: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-nwdiag: markers 'python_version == "3.6"' don't match your environment
Ignoring Pint: markers 'python_version == "3.4"' don't match your environment
Ignoring Pint: markers 'python_version == "3.5"' don't match your environment
Ignoring Pint: markers 'python_version == "3.6"' don't match your environment
Ignoring Pint: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-websupport: markers 'python_version == "2.7"' don't match your environment
Ignoring thriftpy2: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-htmlhelp: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-htmlhelp: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-htmlhelp: markers 'python_version == "3.6"' don't match your environment
Ignoring ipaddress: markers 'python_version == "2.7"' don't match your environment
Ignoring networkx: markers 'python_version == "2.7"' don't match your environment
Ignoring networkx: markers 'python_version == "3.4"' don't match your environment
Ignoring networkx: markers 'python_version == "3.5"' don't match your environment
Ignoring networkx: markers 'python_version == "3.6"' don't match your environment
Ignoring Pillow: markers 'python_version == "2.7"' don't match your environment
Ignoring Pillow: markers 'python_version == "3.4"' don't match your environment
Ignoring Pillow: markers 'python_version == "3.5"' don't match your environment
Ignoring Pillow: markers 'python_version == "3.6"' don't match your environment
Ignoring zeroconf: markers 'python_version == "2.7"' don't match your environment
Ignoring zeroconf: markers 'python_version == "3.4"' don't match your environment
Ignoring zeroconf: markers 'python_version == "3.5"' don't match your environment
Ignoring zeroconf: markers 'python_version == "3.6"' don't match your environment
Ignoring scipy: markers 'python_version == "2.7"' don't match your environment
Ignoring scipy: markers 'python_version == "3.4"' don't match your environment
Ignoring scipy: markers 'python_version == "3.5"' don't match your environment
Ignoring scipy: markers 'python_version == "3.6"' don't match your environment
Ignoring mypy-extensions: markers 'python_version == "3.4"' don't match your environment
Ignoring mypy-extensions: markers 'python_version == "3.5"' don't match your environment
Ignoring mypy-extensions: markers 'python_version == "3.6"' don't match your environment
Ignoring sphinxcontrib-blockdiag: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-blockdiag: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-blockdiag: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-blockdiag: markers 'python_version == "3.6"' don't match your environment
Ignoring ifaddr: markers 'python_version == "3.4"' don't match your environment
Ignoring ifaddr: markers 'python_version == "3.5"' don't match your environment
Ignoring ifaddr: markers 'python_version == "3.6"' don't match your environment
Ignoring unicodecsv: markers 'python_version == "2.7"' don't match your environment
Ignoring pathlib: markers 'python_version == "2.7"' don't match your environment
Ignoring tornado: markers 'python_version == "3.4"' don't match your environment
Ignoring tornado: markers 'python_version == "3.5"' don't match your environment
Ignoring tornado: markers 'python_version == "3.6"' don't match your environment
Ignoring tornado: markers 'python_version == "2.7"' don't match your environment
Ignoring backports.ssl-match-hostname: markers 'python_version == "2.7"' don't match your environment
Ignoring gunicorn: markers 'python_version == "2.7"' don't match your environment
Ignoring gunicorn: markers 'python_version == "3.4"' don't match your environment
Ignoring gunicorn: markers 'python_version == "3.5"' don't match your environment
Ignoring gunicorn: markers 'python_version == "3.6"' don't match your environment
Ignoring asyncio: markers 'python_version == "3.4"' don't match your environment
Ignoring asyncio: markers 'python_version == "3.5"' don't match your environment
Ignoring asyncio: markers 'python_version == "3.6"' don't match your environment
Ignoring sphinxcontrib-jsmath: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-jsmath: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-jsmath: markers 'python_version == "3.6"' don't match your environment
Ignoring sphinxcontrib-serializinghtml: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-serializinghtml: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-serializinghtml: markers 'python_version == "3.6"' don't match your environment
Ignoring M2Crypto: markers 'python_version == "2.7"' don't match your environment
Ignoring influxdb: markers 'python_version == "2.7"' don't match your environment
Ignoring influxdb: markers 'python_version == "3.4"' don't match your environment
Ignoring influxdb: markers 'python_version == "3.5"' don't match your environment
Ignoring influxdb: markers 'python_version == "3.6"' don't match your environment
Ignoring trollius: markers 'python_version == "2.7"' don't match your environment
Ignoring funcsigs: markers 'python_version == "2.7"' don't match your environment
Ignoring dnspython3: markers 'python_version == "3.4"' don't match your environment
Ignoring dnspython3: markers 'python_version == "3.5"' don't match your environment
Ignoring dnspython3: markers 'python_version == "3.6"' don't match your environment
Ignoring joblib: markers 'python_version == "3.4"' don't match your environment
Ignoring joblib: markers 'python_version == "3.5"' don't match your environment
Ignoring joblib: markers 'python_version == "3.6"' don't match your environment
Ignoring enmerkar: markers 'python_version == "3.4"' don't match your environment
Ignoring enmerkar: markers 'python_version == "3.5"' don't match your environment
Ignoring enmerkar: markers 'python_version == "3.6"' don't match your environment
Ignoring mypy: markers 'python_version == "3.4"' don't match your environment
Ignoring mypy: markers 'python_version == "3.5"' don't match your environment
Ignoring mypy: markers 'python_version == "3.6"' don't match your environment
Ignoring sphinxcontrib-seqdiag: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-seqdiag: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-seqdiag: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-seqdiag: markers 'python_version == "3.6"' don't match your environment
Ignoring jeepney: markers 'python_version == "3.4"' don't match your environment
Ignoring jeepney: markers 'python_version == "3.5"' don't match your environment
Ignoring jeepney: markers 'python_version == "3.6"' don't match your environment
Ignoring singledispatch: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-svg2pdfconverter: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-svg2pdfconverter: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-svg2pdfconverter: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-svg2pdfconverter: markers 'python_version == "3.6"' don't match your environment
Ignoring keyring: markers 'python_version == "2.7"' don't match your environment
Ignoring keyring: markers 'python_version == "3.4"' don't match your environment
Ignoring keyring: markers 'python_version == "3.5"' don't match your environment
Ignoring keyring: markers 'python_version == "3.6"' don't match your environment
Ignoring SecretStorage: markers 'python_version == "2.7"' don't match your environment
Ignoring SecretStorage: markers 'python_version == "3.4"' don't match your environment
Ignoring SecretStorage: markers 'python_version == "3.5"' don't match your environment
Ignoring SecretStorage: markers 'python_version == "3.6"' don't match your environment
Ignoring weakrefmethod: markers 'python_version == "2.7"' don't match your environment
Ignoring more-itertools: markers 'python_version == "2.7"' don't match your environment
Ignoring more-itertools: markers 'python_version == "3.4"' don't match your environment
Ignoring more-itertools: markers 'python_version == "3.5"' don't match your environment
Ignoring more-itertools: markers 'python_version == "3.6"' don't match your environment
Ignoring numpy: markers 'python_version == "2.7"' don't match your environment
Ignoring numpy: markers 'python_version == "3.4"' don't match your environment
Ignoring numpy: markers 'python_version == "3.5"' don't match your environment
Ignoring numpy: markers 'python_version == "3.6"' don't match your environment
Ignoring Sphinx: markers 'python_version == "2.7"' don't match your environment
Ignoring Sphinx: markers 'python_version == "3.4"' don't match your environment
Ignoring Sphinx: markers 'python_version == "3.5"' don't match your environment
Ignoring Sphinx: markers 'python_version == "3.6"' don't match your environment
Ignoring Django: markers 'python_version == "2.7"' don't match your environment
Ignoring Django: markers 'python_version == "3.4"' don't match your environment
Ignoring Django: markers 'python_version == "3.5"' don't match your environment
Ignoring Django: markers 'python_version == "3.6"' don't match your environment
Ignoring atomicwrites: markers 'python_version == "2.7"' don't match your environment
Ignoring typed-ast: markers 'python_version == "3.4"' don't match your environment
Ignoring typed-ast: markers 'python_version == "3.5"' don't match your environment
Ignoring typed-ast: markers 'python_version == "3.6"' don't match your environment
Ignoring subprocess32: markers 'python_version == "2.7"' don't match your environment
Ignoring GitPython: markers 'python_version == "2.7"' don't match your environment
Ignoring GitPython: markers 'python_version == "3.4"' don't match your environment
Ignoring GitPython: markers 'python_version == "3.5"' don't match your environment
Ignoring GitPython: markers 'python_version == "3.6"' don't match your environment
Ignoring functools32: markers 'python_version == "2.7"' don't match your environment
Ignoring backports.functools-lru-cache: markers 'python_version == "2.7"' don't match your environment
Ignoring entrypoints: markers 'python_version == "2.7"' don't match your environment
Ignoring cachetools: markers 'python_version == "2.7"' don't match your environment
Ignoring cachetools: markers 'python_version == "3.4"' don't match your environment
Ignoring cachetools: markers 'python_version == "3.5"' don't match your environment
Ignoring cachetools: markers 'python_version == "3.6"' don't match your environment
Ignoring backports-abc: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-qthelp: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-qthelp: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-qthelp: markers 'python_version == "3.6"' don't match your environment
Ignoring qpid-python: markers 'python_version == "2.7"' don't match your environment
Ignoring contextlib2: markers 'python_version == "2.7"' don't match your environment
Ignoring configparser: markers 'python_version == "2.7"' don't match your environment
Ignoring sphinxcontrib-devhelp: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-devhelp: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-devhelp: markers 'python_version == "3.6"' don't match your environment
Ignoring dnspython: markers 'python_version == "3.4"' don't match your environment
Ignoring dnspython: markers 'python_version == "3.5"' don't match your environment
Ignoring dnspython: markers 'python_version == "3.6"' don't match your environment
Ignoring dnspython: markers 'python_version == "2.7"' don't match your environment
Ignoring scandir: markers 'python_version == "2.7"' don't match your environment
Ignoring futures: markers 'python_version == "2.7"' don't match your environment
Ignoring happybase: markers 'python_version == "2.7"' don't match your environment
Ignoring typing-extensions: markers 'python_version == "3.4"' don't match your environment
Ignoring typing-extensions: markers 'python_version == "3.5"' don't match your environment
Ignoring typing-extensions: markers 'python_version == "3.6"' don't match your environment
Ignoring sphinxcontrib-applehelp: markers 'python_version == "3.4"' don't match your environment
Ignoring sphinxcontrib-applehelp: markers 'python_version == "3.5"' don't match your environment
Ignoring sphinxcontrib-applehelp: markers 'python_version == "3.6"' don't match your environment
Ignoring scikit-learn: markers 'python_version == "2.7"' don't match your environment
Ignoring scikit-learn: markers 'python_version == "3.4"' don't match your environment
Ignoring scikit-learn: markers 'python_version == "3.5"' don't match your environment
Ignoring scikit-learn: markers 'python_version == "3.6"' don't match your environment
Collecting pip==19.3
  Downloading https://files.pythonhosted.org/packages/4a/08/6ca123073af4ebc4c5488a5bc8a010ac57aa39ce4d3c8a931ad504de4185/pip-19.3-py2.py3-none-any.whl (1.4MB)
Collecting setuptools==41.4.0
  Downloading https://files.pythonhosted.org/packages/6a/9a/50fadfd53ec909e4399b67c74cc7f4e883488035cfcdb90b685758fa8b34/setuptools-41.4.0-py2.py3-none-any.whl (580kB)
Requirement already up-to-date: wheel==0.33.6 in /openstack/venvs/utility-20.1.0.dev115/lib/python3.7/site-packages (from -c /openstack/venvs/utility-20.1.0.dev115/global-constraints.txt (line 4)) (0.33.6)
Installing collected packages: pip, setuptools
  Found existing installation: pip 19.3.1
    Uninstalling pip-19.3.1:
      Successfully uninstalled pip-19.3.1
  Found existing installation: setuptools 42.0.2
    Uninstalling setuptools-42.0.2:
      Successfully uninstalled setuptools-42.0.2
Successfully installed pip-19.3 setuptools-41.4.0
stdout_lines
[
    "Ignoring argparse: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring enum-compat: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-actdiag: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-actdiag: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-actdiag: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-actdiag: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring pytest: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring pytest: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring pytest: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring pytest: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring sphinxcontrib-nwdiag: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-nwdiag: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-nwdiag: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-nwdiag: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring Pint: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring Pint: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring Pint: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring Pint: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-websupport: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring thriftpy2: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-htmlhelp: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-htmlhelp: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-htmlhelp: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring ipaddress: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring networkx: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring networkx: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring networkx: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring networkx: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring Pillow: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring Pillow: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring Pillow: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring Pillow: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring zeroconf: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring zeroconf: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring zeroconf: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring zeroconf: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring scipy: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring scipy: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring scipy: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring scipy: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring mypy-extensions: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring mypy-extensions: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring mypy-extensions: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring sphinxcontrib-blockdiag: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-blockdiag: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-blockdiag: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-blockdiag: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring ifaddr: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring ifaddr: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring ifaddr: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring unicodecsv: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring pathlib: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring tornado: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring tornado: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring tornado: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring tornado: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring backports.ssl-match-hostname: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring gunicorn: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring gunicorn: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring gunicorn: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring gunicorn: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring asyncio: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring asyncio: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring asyncio: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring sphinxcontrib-jsmath: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-jsmath: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-jsmath: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring sphinxcontrib-serializinghtml: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-serializinghtml: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-serializinghtml: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring M2Crypto: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring influxdb: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring influxdb: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring influxdb: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring influxdb: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring trollius: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring funcsigs: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring dnspython3: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring dnspython3: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring dnspython3: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring joblib: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring joblib: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring joblib: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring enmerkar: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring enmerkar: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring enmerkar: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring mypy: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring mypy: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring mypy: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring sphinxcontrib-seqdiag: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-seqdiag: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-seqdiag: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-seqdiag: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring jeepney: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring jeepney: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring jeepney: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring singledispatch: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-svg2pdfconverter: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-svg2pdfconverter: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-svg2pdfconverter: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-svg2pdfconverter: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring keyring: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring keyring: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring keyring: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring keyring: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring SecretStorage: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring SecretStorage: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring SecretStorage: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring SecretStorage: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring weakrefmethod: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring more-itertools: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring more-itertools: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring more-itertools: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring more-itertools: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring numpy: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring numpy: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring numpy: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring numpy: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring Sphinx: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring Sphinx: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring Sphinx: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring Sphinx: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring Django: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring Django: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring Django: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring Django: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring atomicwrites: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring typed-ast: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring typed-ast: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring typed-ast: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring subprocess32: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring GitPython: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring GitPython: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring GitPython: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring GitPython: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring functools32: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring backports.functools-lru-cache: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring entrypoints: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring cachetools: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring cachetools: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring cachetools: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring cachetools: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring backports-abc: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-qthelp: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-qthelp: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-qthelp: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring qpid-python: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring contextlib2: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring configparser: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring sphinxcontrib-devhelp: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-devhelp: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-devhelp: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring dnspython: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring dnspython: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring dnspython: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring dnspython: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring scandir: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring futures: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring happybase: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring typing-extensions: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring typing-extensions: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring typing-extensions: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring sphinxcontrib-applehelp: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring sphinxcontrib-applehelp: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring sphinxcontrib-applehelp: markers 'python_version == \"3.6\"' don't match your environment",
    "Ignoring scikit-learn: markers 'python_version == \"2.7\"' don't match your environment",
    "Ignoring scikit-learn: markers 'python_version == \"3.4\"' don't match your environment",
    "Ignoring scikit-learn: markers 'python_version == \"3.5\"' don't match your environment",
    "Ignoring scikit-learn: markers 'python_version == \"3.6\"' don't match your environment",
    "Collecting pip==19.3",
    "  Downloading https://files.pythonhosted.org/packages/4a/08/6ca123073af4ebc4c5488a5bc8a010ac57aa39ce4d3c8a931ad504de4185/pip-19.3-py2.py3-none-any.whl (1.4MB)",
    "Collecting setuptools==41.4.0",
    "  Downloading https://files.pythonhosted.org/packages/6a/9a/50fadfd53ec909e4399b67c74cc7f4e883488035cfcdb90b685758fa8b34/setuptools-41.4.0-py2.py3-none-any.whl (580kB)",
    "Requirement already up-to-date: wheel==0.33.6 in /openstack/venvs/utility-20.1.0.dev115/lib/python3.7/site-packages (from -c /openstack/venvs/utility-20.1.0.dev115/global-constraints.txt (line 4)) (0.33.6)",
    "Installing collected packages: pip, setuptools",
    "  Found existing installation: pip 19.3.1",
    "    Uninstalling pip-19.3.1:",
    "      Successfully uninstalled pip-19.3.1",
    "  Found existing installation: setuptools 42.0.2",
    "    Uninstalling setuptools-42.0.2:",
    "      Successfully uninstalled setuptools-42.0.2",
    "Successfully installed pip-19.3 setuptools-41.4.0"
]
version None
virtualenv
/openstack/venvs/utility-20.1.0.dev115