Details

Result

Field Value
changed
True
msg
All items completed
results
[
    {
        "ansible_loop_var": "item",
        "changed": true,
        "cmd": [
            "/usr/bin/zypper",
            "--quiet",
            "--non-interactive",
            "--xmlout",
            "install",
            "--type",
            "package",
            "--auto-agree-with-licenses",
            "--no-recommends",
            "--",
            "+audit-audispd-plugins",
            "+aide",
            "+dracut-fips",
            "+screen"
        ],
        "failed": false,
        "invocation": {
            "module_args": {
                "disable_gpg_check": false,
                "disable_recommends": true,
                "extra_args": null,
                "extra_args_precommand": null,
                "force": false,
                "name": [
                    "audit-audispd-plugins",
                    "audit",
                    "aide",
                    "dracut-fips",
                    "openssh",
                    "screen"
                ],
                "oldpackage": false,
                "state": "present",
                "type": "package",
                "update_cache": false
            }
        },
        "item": "present",
        "name": [
            "audit-audispd-plugins",
            "audit",
            "aide",
            "dracut-fips",
            "openssh",
            "screen"
        ],
        "rc": 0,
        "state": "present",
        "stderr": "",
        "stderr_lines": [],
        "stdout": "<?xml version='1.0'?>\n<stream>\n<install-summary download-size=\"902872\" space-usage-diff=\"1949372\" packages-to-change=\"9\">\n<to-install>\n<solvable type=\"package\" name=\"aide\" edition=\"0.16-lp151.3.3.1\" arch=\"x86_64\" summary=\"Advanced Intrusion Detection Environment\">\n<description>AIDE is an intrusion detection system that checks file integrity.</description></solvable>\n<solvable type=\"package\" name=\"audit-audispd-plugins\" edition=\"2.8.1-lp151.4.4\" arch=\"x86_64\" summary=\"Default plugins for the audit dispatcher\">\n<description>The audit-audispd-plugins package contains plugin components for the\naudit dispatcher (audispd).</description></solvable>\n<solvable type=\"package\" name=\"dracut-fips\" edition=\"044.2-lp151.2.9.1\" arch=\"x86_64\" summary=\"Dracut modules to build a dracut initramfs with an integrity check\">\n<description>This package requires everything which is needed to build an\ninitramfs with dracut, which does an integrity check of the kernel\nand its cryptography during startup.</description></solvable>\n<solvable type=\"package\" name=\"fipscheck\" edition=\"1.4.1-lp151.3.3.1\" arch=\"x86_64\" summary=\"A library for integrity verification of FIPS validated modules\">\n<description>FIPSCheck is a library for integrity verification of FIPS validated\nmodules. The package also provides helper binaries for creation and\nverification of the HMAC-SHA256 checksum files.</description></solvable>\n<solvable type=\"package\" name=\"libcryptsetup12-hmac\" edition=\"2.0.5-lp151.1.17\" arch=\"x86_64\" summary=\"Checksums for libcryptsetup4\">\n<description>This package contains HMAC checksums for integrity checking of libcryptsetup4,\nused for FIPS.</description></solvable>\n<solvable type=\"package\" name=\"libfipscheck1\" edition=\"1.4.1-lp151.3.3.1\" arch=\"x86_64\" summary=\"Library files for fipscheck\">\n<description>This package contains the FIPSCheck library.</description></solvable>\n<solvable type=\"package\" name=\"libgcrypt20-hmac\" edition=\"1.8.2-lp151.9.7.1\" arch=\"x86_64\" summary=\"HMAC checksums for the GNU Crypto Library\">\n<description>Libgcrypt is a general purpose crypto library based on the code used in\nGnuPG (alpha version). This package contains the HMAC checksum files\nfor integrity checking the library, as required by FIPS 140-2.</description></solvable>\n<solvable type=\"package\" name=\"libkcapi-tools\" edition=\"0.13.0-lp151.2.50\" arch=\"x86_64\" summary=\"Linux Kernel Crypto API User Space Tools\">\n<description>libkcapi user space tools to access certain hash algorithms.</description></solvable>\n<solvable type=\"package\" name=\"screen\" edition=\"4.6.2-lp151.4.67\" arch=\"x86_64\" summary=\"A program to allow multiple screens on a VT100/ANSI Terminal\">\n<description>With this program you can take advantage of the multitasking abilities\nof your Linux system by opening several sessions over one terminal. The\nsessions can also be detached and resumed from another login terminal.\n\nDocumentation: man page</description></solvable>\n</to-install>\n</install-summary>\n<prompt id=\"0\">\n<text>Continue?</text>\n<option default=\"1\" value=\"y\" desc=\"Yes, accept the summary and proceed with installation/removal of packages.\"/>\n<option value=\"n\" desc=\"No, cancel the operation.\"/>\n<option value=\"v\" desc=\"Toggle display of package versions.\"/>\n<option value=\"a\" desc=\"Toggle display of package architectures.\"/>\n<option value=\"r\" desc=\"Toggle display of repositories from which the packages will be installed.\"/>\n<option value=\"m\" desc=\"Toggle display of package vendor names.\"/>\n<option value=\"d\" desc=\"Toggle between showing all details and as few details as possible.\"/>\n<option value=\"g\" desc=\"View the summary in pager.\"/>\n</prompt>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/audit-audispd-plugins-2.8.1-lp151.4.4.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/audit-audispd-plugins-2.8.1-lp151.4.4.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/libcryptsetup12-hmac-2.0.5-lp151.1.17.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/libcryptsetup12-hmac-2.0.5-lp151.1.17.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/libkcapi-tools-0.13.0-lp151.2.50.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/libkcapi-tools-0.13.0-lp151.2.50.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/screen-4.6.2-lp151.4.67.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/screen-4.6.2-lp151.4.67.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/aide-0.16-lp151.3.3.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/aide-0.16-lp151.3.3.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/fipscheck-1.4.1-lp151.3.3.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/fipscheck-1.4.1-lp151.3.3.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/libgcrypt20-hmac-1.8.2-lp151.9.7.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/libgcrypt20-hmac-1.8.2-lp151.9.7.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/libfipscheck1-1.4.1-lp151.3.3.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/libfipscheck1-1.4.1-lp151.3.3.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/dracut-fips-044.2-lp151.2.9.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>\n<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/dracut-fips-044.2-lp151.2.9.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>\n</stream>\n",
        "stdout_lines": [
            "<?xml version='1.0'?>",
            "<stream>",
            "<install-summary download-size=\"902872\" space-usage-diff=\"1949372\" packages-to-change=\"9\">",
            "<to-install>",
            "<solvable type=\"package\" name=\"aide\" edition=\"0.16-lp151.3.3.1\" arch=\"x86_64\" summary=\"Advanced Intrusion Detection Environment\">",
            "<description>AIDE is an intrusion detection system that checks file integrity.</description></solvable>",
            "<solvable type=\"package\" name=\"audit-audispd-plugins\" edition=\"2.8.1-lp151.4.4\" arch=\"x86_64\" summary=\"Default plugins for the audit dispatcher\">",
            "<description>The audit-audispd-plugins package contains plugin components for the",
            "audit dispatcher (audispd).</description></solvable>",
            "<solvable type=\"package\" name=\"dracut-fips\" edition=\"044.2-lp151.2.9.1\" arch=\"x86_64\" summary=\"Dracut modules to build a dracut initramfs with an integrity check\">",
            "<description>This package requires everything which is needed to build an",
            "initramfs with dracut, which does an integrity check of the kernel",
            "and its cryptography during startup.</description></solvable>",
            "<solvable type=\"package\" name=\"fipscheck\" edition=\"1.4.1-lp151.3.3.1\" arch=\"x86_64\" summary=\"A library for integrity verification of FIPS validated modules\">",
            "<description>FIPSCheck is a library for integrity verification of FIPS validated",
            "modules. The package also provides helper binaries for creation and",
            "verification of the HMAC-SHA256 checksum files.</description></solvable>",
            "<solvable type=\"package\" name=\"libcryptsetup12-hmac\" edition=\"2.0.5-lp151.1.17\" arch=\"x86_64\" summary=\"Checksums for libcryptsetup4\">",
            "<description>This package contains HMAC checksums for integrity checking of libcryptsetup4,",
            "used for FIPS.</description></solvable>",
            "<solvable type=\"package\" name=\"libfipscheck1\" edition=\"1.4.1-lp151.3.3.1\" arch=\"x86_64\" summary=\"Library files for fipscheck\">",
            "<description>This package contains the FIPSCheck library.</description></solvable>",
            "<solvable type=\"package\" name=\"libgcrypt20-hmac\" edition=\"1.8.2-lp151.9.7.1\" arch=\"x86_64\" summary=\"HMAC checksums for the GNU Crypto Library\">",
            "<description>Libgcrypt is a general purpose crypto library based on the code used in",
            "GnuPG (alpha version). This package contains the HMAC checksum files",
            "for integrity checking the library, as required by FIPS 140-2.</description></solvable>",
            "<solvable type=\"package\" name=\"libkcapi-tools\" edition=\"0.13.0-lp151.2.50\" arch=\"x86_64\" summary=\"Linux Kernel Crypto API User Space Tools\">",
            "<description>libkcapi user space tools to access certain hash algorithms.</description></solvable>",
            "<solvable type=\"package\" name=\"screen\" edition=\"4.6.2-lp151.4.67\" arch=\"x86_64\" summary=\"A program to allow multiple screens on a VT100/ANSI Terminal\">",
            "<description>With this program you can take advantage of the multitasking abilities",
            "of your Linux system by opening several sessions over one terminal. The",
            "sessions can also be detached and resumed from another login terminal.",
            "",
            "Documentation: man page</description></solvable>",
            "</to-install>",
            "</install-summary>",
            "<prompt id=\"0\">",
            "<text>Continue?</text>",
            "<option default=\"1\" value=\"y\" desc=\"Yes, accept the summary and proceed with installation/removal of packages.\"/>",
            "<option value=\"n\" desc=\"No, cancel the operation.\"/>",
            "<option value=\"v\" desc=\"Toggle display of package versions.\"/>",
            "<option value=\"a\" desc=\"Toggle display of package architectures.\"/>",
            "<option value=\"r\" desc=\"Toggle display of repositories from which the packages will be installed.\"/>",
            "<option value=\"m\" desc=\"Toggle display of package vendor names.\"/>",
            "<option value=\"d\" desc=\"Toggle between showing all details and as few details as possible.\"/>",
            "<option value=\"g\" desc=\"View the summary in pager.\"/>",
            "</prompt>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/audit-audispd-plugins-2.8.1-lp151.4.4.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/audit-audispd-plugins-2.8.1-lp151.4.4.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/libcryptsetup12-hmac-2.0.5-lp151.1.17.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/libcryptsetup12-hmac-2.0.5-lp151.1.17.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/libkcapi-tools-0.13.0-lp151.2.50.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/libkcapi-tools-0.13.0-lp151.2.50.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/screen-4.6.2-lp151.4.67.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/distribution/leap/15.1/repo/oss/x86_64/screen-4.6.2-lp151.4.67.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/aide-0.16-lp151.3.3.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/aide-0.16-lp151.3.3.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/fipscheck-1.4.1-lp151.3.3.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/fipscheck-1.4.1-lp151.3.3.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/libgcrypt20-hmac-1.8.2-lp151.9.7.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/libgcrypt20-hmac-1.8.2-lp151.9.7.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/libfipscheck1-1.4.1-lp151.3.3.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/libfipscheck1-1.4.1-lp151.3.3.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/dracut-fips-044.2-lp151.2.9.1.x86_64.rpm\" percent=\"-1\" rate=\"-1\"/>",
            "<download url=\"http://mirror.ord.rax.opendev.org/opensuse/update/leap/15.1/oss/x86_64/dracut-fips-044.2-lp151.2.9.1.x86_64.rpm\" rate=\"-1\" done=\"1\"/>",
            "</stream>"
        ],
        "update_cache": false
    }
]